Error on default encoding

Aug 5, 2016 at 12:41 PM
I notice using this class on Release on Android via Xamarin, it raise an exception
""
on this line
private static Encoding DefaultEncoding = Encoding.GetEncoding(437);

i can substituite with
private static Encoding DefaultEncoding = Encoding.DefaultEncoding;
Coordinator
Aug 10, 2016 at 1:05 PM
Hi polipo,

Just found your message here in codeplex. Notice that ZipStorer is not being maintained anymore here. Please refer to the github page: https://github.com/jaime-olivares/zipstorer . There you can raise an issue.

Regarding your issue, thanks for reporting. Is there any error message? Not sure how to handle it, because, according to the spec, 437 should be the default encoding.
Anyway I will keep an eye on it.

-Jaime.
Aug 10, 2016 at 1:18 PM

Dear,

this occour only on Android with Xamarin, i have changed the line with the default encoding.

The error tell “…437 not supported…”

Da: jaime_olivares [email removed]
Inviato: mercoledì 10 agosto 2016 15:06
A: [email removed]
Oggetto: Re: Error on default encoding [zipstorer:656950]

From: jaime_olivares

Hi polipo,

Just found your message here in codeplex. Notice that ZipStorer is not being maintained anymore here. Please refer to the github page: https://github.com/jaime-olivares/zipstorer . There you can raise an issue.

Regarding your issue, thanks for reporting. Is there any error message? Not sure how to handle it, because, according to the spec, 437 should be the default encoding.
Anyway I will keep an eye on it.

-Jaime.

Coordinator
Aug 10, 2016 at 3:16 PM

It is funny it is also happening with SharpZipLib:

http://forums.xamarin.com/discussion/13644/how-to-handle-exepction-codepage-437-not-supported

Will keep looking at it

From: polipo <[email removed]>
Reply-To: <[email removed]>
Date: Wednesday, August 10, 2016 at 08:18
To: Jaime Olivares <[email removed]>
Subject: Re: Error on default encoding [zipstorer:656950]

From: polipo

Dear,

this occour only on Android with Xamarin, i have changed the line with the default encoding.

The error tell “…437 not supported…”

Da: jaime_olivares [email removed]
Inviato: mercoledì 10 agosto 2016 15:06
A: [email removed]
Oggetto: Re: Error on default encoding [zipstorer:656950]

From: jaime_olivares

Hi polipo,

Just found your message here in codeplex. Notice that ZipStorer is not being maintained anymore here. Please refer to the github page: https://github.com/jaime-olivares/zipstorer . There you can raise an issue.

Regarding your issue, thanks for reporting. Is there any error message? Not sure how to handle it, because, according to the spec, 437 should be the default encoding.
Anyway I will keep an eye on it.

-Jaime.